After upgrading the Jmix BOM version from 2.8.5 to 2.8.6 for an application using two additional datastores, the application refuses starting.
app | 2026-10-07T11:08:11.206+02:00 WARN 1 --- [ main] i.j.d.i.JmixBaseEntityManagerFactoryBean : Cannot find persistence.xml for 'messagestore' store. Falling back to classpath scan for entity classes.
app | In case of problems, please make sure that the property 'jmix.core.additional-stores' is defined in application.properties and contains this store name, or that at least one entity with the '@Store(name = "messagestore")' annotation is present.
app | 2026-10-07T11:08:13.048+02:00 WARN 1 --- [ main] o.s.c.annotation.AnnotationTypeMapping : Support for convention-based annotation attribute overrides is deprecated and will be removed in Spring Framework 7.0. Please annotate the following attributes in @javax.annotation.RegEx with appropriate @AliasFor declarations: [when]
app | 2026-10-07T11:08:14.838+02:00 WARN 1 --- [ main] ConfigServletWebServerApplicationContext : Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'messagestoreEntityManagerFactory' defined in class path resource [com/layertec/app/mmc/datastore/MessagesDataStoreConfiguration.class]: Failed to read candidate component class: URL [jar:file:/app/libs/atmosphere-runtime-3.0.5.slf4jvaadin1.jar!/org/atmosphere/inject/AtmosphereRequestIntrospector.class]
The instance refusing to start is built as docker image using com.bmuschko.docker-spring-boot-application (Version 9.4.0) - it was built and running with Jmix 2.8.5 before.
When trying to rebuild locally another confusing behaviour showed up:
The following Liquibase changelog include has been removed from the main datastore changelog file:
<include file="/io/jmix/securitydata/liquibase/changelog.xml"
Maybe that’s just subsequent error.
The image has been rebuilt by the CI environment (always clean). But I did not rebuild it clean in a local environment before.
Is the change possibly related to Unreliable entity enhancement and descriptor generation (port to 2.8) ?
Additional information: I compared the images and noticed - with Jmix 2.8.6 all *orm.xml and all *persistence.xmlfiles are missing - main and additional datastores.