Failed to undeploy .war from Tomcat

I created .war by using gradlew bootJar and manually deploy to Tomcat 9.0.16. However when I deleted war and Tomcat failed to delete the exploded folder. Logs are:

scratch_6.log (15.0 KB)

It seems some threads in thread pool are not stopped. Their names are pool-4-thread-1,core-1, core-2, ui_backgroundScheduler1, core-3.

Note: Database mysql and oracle produce same problem. CUBA doesn’t has this problem.

These are files cannot be removed after undeploy WAR using tomcat web manager.

I just tried, and everything worked fine for me - web application has been successfully undeployed.
Try the latest tomcat version (it is 9.0.55). If it doesn’t help, then tell us your OS and java version.

1 Like

Thanks for your reply, I’ll try!

Your answer is correct. I made it after updating tomcat to 9.0.52 or 9.0.56!

I’m facing the same exception with auto deploy on tomcat 9.0.62

What Jmix add-ons are you using in the application?

Just Data Tools

I confirm that the problem exists in Jmix 1.2.3.
Created issue: