Ldap addon drives me crazy :(


until now we do not understand,
how the LDAP addon together with AD is working.

We have 2 apps.
One got created with JMIX.
In that app we can login on the war deployment on the server using ldap.
But, when we run it local as bootRun,
we only see the info: unknown login name or bad password

The other app got created with Cuba and then migrated to JMIX.
The relevant settings are completely identical with the other one.
But, even the deployed war on the server just shows: unknown login name or bad password.
On the same server the Cuba apps are working fine with the ldap login.

I went through all docs and threads, but actually I do not see any logic behind that.

How to find out,
what’s going wrong.


one mistake in the description:
the pure JMIX app works fine with LDAP AddOn, deployed as war on server and also as bootRun locally.

I compared all settings in application.properties and build.gradle… I cannot find any difference…

I’ve just tried the following:

  1. Created a new CUBA app
  2. Migrated it to Jmix
  3. Added the LDAP add-on to the migrated Jmix project
  4. Configured the Jmix project to work with forumsys online LDAP server as described in the documentation
  5. Build the WAR file
  6. Deployed the WAR file to Tomcat, started the tomcat

I was able to successfully login using LDAP credentials.

You may try to reproduce the same steps with the new project on your side - maybe you’ll find something.
Did you create a Synchronization strategy by the way?
Are there errors in tomcat logs?

1 Like

Hi Maxim,

thx for your answer.
I played around with LdapUserDetailsSynchronizationStrategy and also
created a component to extend the LdapSecurityConfiguration…

Now it works fine.
I need some more time to really understand what’s going on,
but this issue is resolved.


Hi Maxim,

I opened a new thread for an open question related to a behaviour we cannot explain.
[AD Ldap login not working without extending LdapSecurityConfiguration - Support - Jmix]