Migration from JMIX 1.0.0 to 1.1.4 activates liquibase


On JMIX 1.0.0 I’ve deactivated liquibase putting on application.properties comments before these 3 lines:
#main.datasource.jdbcUrl = …
#main.datasource.username = …
#main.datasource.password =…

and putting these configurations back in application.dev file. application.dev file is executing when compiling as log shows. (I’ve put in Run,configuration, environment variables,spring.profiles.active=dev)

After migrated to 1.1.4, liquibase log started to pop up even the above configurations remains the same.

How can I deactivate again liquibase it because it makes a mess on my database that is used by a lot of shared apps and is managed with other tools ?


The same is also with latest verison
intelij 2022.1 and jmix plugin version 1.2.1-213

I found 2 options on build,
jmix application and myapp jmix application and found that on second option launches liquibase due to an option checked there.
So it is ok finally.

You can disable generation of Liquibase changelogs before starting the application by removing the “Check Jmix Database” action from your Run/Debug Configuration:


Yes, I found it by chance :slight_smile: finally. Thanks.