Project data format strings not saved?

I tried to change the data format strings for different Languages.
Maybe I am doing it wrong, but it looks like, they are not saved anywhere.
Using the current version of JMIX…
Is there any trick to do it?

And I also cannot change the dateformat in the …browse.xml
Took out the day, but still shown in the screen.


Regards Roland

Could you please provide more information about your problem? Did you try to set up data formats as it described in documentation? Which version of the Jmix platform do you use in the project? Please share with us information from the Product Version section in the Welcome screen. You can easily copy it by clicking Copy.



yes, I did.
After installing the new 1.03 version and the actual plugin,
I see a change.
The project has 2 languages, en and de.
When I set a datetime format for the second one,
now it saves it to the message _de file.
But not for the first one, the en.

After adding it manually to the message_en file,
it is also visible in the GUI.

So, for me it works now, directly adding it to the files.

But, trying to change the dateformat in the descriptor does still not work for me.
column id=“logCreatedOn” dateFormat=“MM” caption=“test”/>
In the GUI I can see the test caption, but whatever I try for the dateFormat,
it is not shown/used in the screen at runtime.


Hi @r.walde

According to documentation you should use a nested formatter element that allows you to represent the attribute value in a format different from the standard for this Datatype.

dateFormat attribute is used if table is configured to inline editing.